Ubuntu機械学習

Ubuntuにwp2txt メモ

機械学習の環境構築時にちょっと苦戦したので忘れないようにメモ。

ruby2.5.1がインストール済みなので簡単に出来ると思ったけど、wp2txtがコマンドがありませんと出る。

sudo gem install wp2txt でインストールできず、nokogiriが必要だといわれる。

nokogiriをインストールする為、sudo apt-get install ruby2.5.1-dev で開発者バージョンをインストール。

sudo gem install nokogiri でnokogiriをインストール。

sudo gem install wp2txt でwp2txtをインストール。

wp2txt –input-file ファイルパス/ファイル名で出来ました。

コメントを残す